WSLのMySQLでアップグレード失敗

問題

  • apt-get install mysql-server で mysql_upgrade: Got error: 2002: というエラーが出る。

解決方法

sudo apt-get remove --purge 'mysql*'
sudo rm -rf /etc/mysql /var/lib/mysql
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get install mysql-server
  • 上のコマンドを実行して、MySQLを完全に削除した上で、インストールしなおす。

参考

https://github.com/Microsoft/WSL/issues/1332


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS

Last-modified: 2018-08-01 (水) 19:25:36 (19d)